Some questions/bugs/inconsistencies

You are here: Home > Forum > Simulations > Released > Stafford > Some questions/bugs/inconsistencies

Page 1 of 1

Some questions/bugs/inconsistencies 04/08/2014 at 18:28 #63514
peterb
Avatar
394 posts
Thanks for refreshing and updating this great sim.

- Church Lane & Meaford crossings penalise you after they've been down for three minutes, Hademore is longer at six. Why the difference? Three minutes is not as long as other sims IIRC.

- Why is it when a train has fully passed CH64 (but not the clearing point), so circuit RUR1 is shown as unoccupied on the Colwich panel, does the same circuit on the Brereton panel still show as occupied until the train has passed the clearing point of CH64? (This may however be standard AB regs for Brereton panel)

- Rugeley Town reversal bug (already reported)

- The annotation 'to Brereton Sidings' I believe is from old Stafford simsig when the Brereton Panel was not simulated. The location of Brereton sidings however isn't otherwise specified on the panel at all so would it not be more logical to have 'to Rugeley Town/Hednesford'?

- As I believe I already noted, is it more appropriate to rename the location 'Rugeley' to 'Rugeley Trent Valley' for differentiation/clarification

- What does '*MS' at Rugeley TV p1 mean.

- Is there any reason why the overlap of signal LD47 never drops?

- On the vintage F2 view, moving the column boundaries has no effect (the default column width is always maintained). This can mean text in the 'Description' column for example is not wrapped.

- I had a passing down train (no platform specified) from Stafford TV Jn through towards Norton Bridge report a wrong route when I tried to send it down the RMT platform. Why was this?

- Also, in developer mode, a vast proportion of trains enter with one minute delay added. This is something which also occurs in Aston. Bug?

From the wiki page:

- Armitage Jn is not a mandatory location; Rugeley North Jn is.
- 'Stone Junction' does not exist as a location - the manual should read 'Stone'
- I'm also not convinced manual path codes are necessary.

Last edited: 04/08/2014 at 19:25 by peterb
Log in to reply
The following user said thank you: Gwasanaethau
Some questions/bugs/inconsistencies 04/08/2014 at 19:47 #63515
Hpotter
Avatar
205 posts
Hi, just a quick response in passing, but i shall endeavor to respond later on properly when I return.
Log in to reply
Some questions/bugs/inconsistencies 04/08/2014 at 21:42 #63523
Gwasanaethau
Avatar
452 posts
Ah, yes. I noticed the RMT platform ‘wrong route’ a couple of weeks ago and completely forgot to report it myself. Thanks for highlighting it!
Log in to reply
Some questions/bugs/inconsistencies 09/08/2014 at 13:03 #63676
Hpotter
Avatar
205 posts
* Church Lane and Meaford crossings are set for 3 mins, this has now been increased as had missed them.
* Section working as per the box for the AB section.
* Brereton Sidings is the name of the box being simulated (Brereton workstation).
* #MS is Middle Siding
* As for the overlap on LD47, which version of the simulation are you running?
* F2 issue is a generic core code, might be worth trying on the latest loader?
* The RMT Area is for freight trains only, this is location os needed for all trains that are required to use it.
* Would seem like the WTT has saved the delay states, try unsing the 'cleanse wtt' option from the F4 menu?

Hope that this helps, but as per the normal, please feel free to update / ask etc.

Log in to reply
Some questions/bugs/inconsistencies 09/08/2014 at 14:32 #63679
Albert
Avatar
601 posts
" said:
* The RMT Area is for freight trains only, this is location os needed for all trains that are required to use it.

Would be useful if the RMT can be used as a loop for a goods train timetabled through Stafford without needing to edit the timetable. If I remember correctly freight also calls for wrong route if routed there.

AJP in games
Log in to reply
Some questions/bugs/inconsistencies 09/08/2014 at 14:44 #63680
peterb
Avatar
394 posts
Thanks for your responses:

* As for the overlap on LD47, which version of the simulation are you running? Sim v3 build 14.
* F2 issue is a generic core code, might be worth trying on the latest loader? Loader v4.1.2.
* The RMT Area is for freight trains only, this is location os needed for all trains that are required to use it. Just to clarify it was a freight train which I sent through on this line. Can these trains not use this line as an avoider without penalty?
* Would seem like the WTT has saved the delay states, try unsing the 'cleanse wtt' option from the F4 menu? Frustratingly this facility isn't available on my F4. What's more is that this is in developer mode, I'd expect all trains to enter on time.

Log in to reply
Some questions/bugs/inconsistencies 09/08/2014 at 16:56 #63685
jc92
Avatar
2628 posts
" said:
" said:
* The RMT Area is for freight trains only, this is location os needed for all trains that are required to use it.

Would be useful if the RMT can be used as a loop for a goods train timetabled through Stafford without needing to edit the timetable. If I remember correctly freight also calls for wrong route if routed there.
and how about TT's written before the RMT was opened? surely its a valid diversionary route anyway.

Log in to reply
Some questions/bugs/inconsistencies 09/08/2014 at 17:23 #63687
onlydjw
Avatar
456 posts
Or when Freightliner ran round coal trains in there?

Last summer when I did an overnight there, 80% of the freight overnight ran through the RMT platform (due to planned possessions) - not one was booked anywhere other than Stafford.

God bless, Daniel Wilson
Last edited: 09/08/2014 at 17:23 by onlydjw
Log in to reply
Some questions/bugs/inconsistencies 09/08/2014 at 20:02 #63699
Peter Bennet
Avatar
4584 posts
" said:
Thanks for your responses:

* Would seem like the WTT has saved the delay states, try unsing the 'cleanse wtt' option from the F4 menu? Frustratingly this facility isn't available on my F4. What's more is that this is in developer mode, I'd expect all trains to enter on time.
Not if the delay has already been saved into the timetable, which is what I think Howard is saying.

Peter

One of the great problems of our age is that we are governed by people who care more about feelings than they do about thoughts and ideas.
Last edited: 09/08/2014 at 20:02 by Peter Bennet
Log in to reply
Some questions/bugs/inconsistencies 09/08/2014 at 20:31 #63702
postal
Avatar
3822 posts
" said:
" said:
Thanks for your responses:

* Would seem like the WTT has saved the delay states, try unsing the 'cleanse wtt' option from the F4 menu? Frustratingly this facility isn't available on my F4. What's more is that this is in developer mode, I'd expect all trains to enter on time.
Not if the delay has already been saved into the timetable, which is what I think Howard is saying.

Peter
The Cleanse TT option is available on the Dev tab in the F4 window which I think only displays if your have a Tester licence or better for the sim. It would be nice if the option was available on one of the other 2 Tools tabs so I've put in on the Issue Tracker as ticket 11352.

"Always forgive your enemies -- nothing annoys them so much" - Oscar Wilde (16/10/1854 – 30/11/1900), Irish poet and playwright.
Log in to reply
The following users said thank you: sloppyjag, peterb
Some questions/bugs/inconsistencies 09/08/2014 at 20:49 #63706
peterb
Avatar
394 posts
" said:
Not if the delay has already been saved into the timetable, which is what I think Howard is saying.
Yes, but this is not the behaviour being exhibited. Let me clarify:

All trains in the timetable originally have 0 minutes delay. Despite this, some freight and pax trains are still entering with a one minute delay flag.

This is always in developer mode with no delays etc set in F3, so not behaviour I would expect to see.

As I said, I have witnessed this same behaviour on Aston.

This is not a case of a timetable being saved repeatedly reinforcing delay flags. Since I need to save the timetable though, to remove delay flags I need to go through each train and reset them manually; since it is a loader sim I can't use convdata. Why don't I have the F4 option to cleanse a timetable? It would be incredibly helpful.

Hopefully this enlightens you. I appreciate this isn't a Stafford-specific bug however I would appreciate an explanation please.

e: Written while postal was also responding. Howard, please can you also tell us what you think re: "is it more appropriate to rename the location 'Rugeley' to 'Rugeley Trent Valley' for differentiation/clarification", unless I'm not reading carefully enough I can't see a response to this, thanks.

Last edited: 09/08/2014 at 20:52 by peterb
Log in to reply
Some questions/bugs/inconsistencies 28/09/2014 at 15:08 #64750
ipswich
Avatar
245 posts
hi all

whilst playing a private game of stafford this afternoon i rang stoke PSB asking for a block on the up main and i also rang Basford Hall Box for a block on the up fast both boxes acknowledged i had asked for a block but a train has since entered on panel at both locations on the lines i had requested screenshots posted so you can have a look

mods please feel free to move to appropriate section if wrong area

thanks
Callum

Post has attachments. Log in to view them.
Log in to reply
Some questions/bugs/inconsistencies 19/12/2014 at 15:59 #66838
paul87101
Avatar
53 posts
Hi,

I am developing a number of TTs on WCML and West Mids but cannot release any of them as I do not have a "Cleanse" option on my F4 menu.

Is this going to be corrected soon or would an admin be willing to cleanse a TT and return to me?

Thanks

Paul

Log in to reply
Some questions/bugs/inconsistencies 19/12/2014 at 16:04 #66839
Danny252
Avatar
1458 posts
Online
Why do you want to cleanse them? Delays are no longer stored in TTs, and so as far as I'm aware, cleansing has not been necessary for years.
Last edited: 19/12/2014 at 16:04 by Danny252
Log in to reply
Some questions/bugs/inconsistencies 19/12/2014 at 16:18 #66840
postal
Avatar
3822 posts
" said:
Hi,

I am developing a number of TTs on WCML and West Mids but cannot release any of them as I do not have a "Cleanse" option on my F4 menu.

Is this going to be corrected soon or would an admin be willing to cleanse a TT and return to me?

Thanks

Paul
Paul

Further to Danny's note, this was recently discussed in this thread. Basically the TT now resets to Day Zero when the sim is loaded then the scenario selected adds in appropriate delays. If the sim has a "perfect" option, you should in theory get a clean TT by starting a session and immediately saving the TT. However, there is now no need for complicated housekeeping as any delays embedded in the TT are discounted whenever a sim is loaded.

"Always forgive your enemies -- nothing annoys them so much" - Oscar Wilde (16/10/1854 – 30/11/1900), Irish poet and playwright.
Log in to reply
The following user said thank you: paul87101
Some questions/bugs/inconsistencies 14/02/2015 at 15:28 #69189
John
Avatar
879 posts
I'm running through my West Hampstead 2015 timetable, and every train from Wellingborough is entering a minute late.

I have tried starting the timetable in easy mode and immediately saving it in order to get a 'clean' timetable, but they're still entering late.

Log in to reply
Some questions/bugs/inconsistencies 14/02/2015 at 19:02 #69201
postal
Avatar
3822 posts
" said:
I'm running through my West Hampstead 2015 timetable, and every train from Wellingborough is entering a minute late.

I have tried starting the timetable in easy mode and immediately saving it in order to get a 'clean' timetable, but they're still entering late. :(
Previously reported here on the Forum and logged on the issue tracker as #12191.

"Always forgive your enemies -- nothing annoys them so much" - Oscar Wilde (16/10/1854 – 30/11/1900), Irish poet and playwright.
Log in to reply
Some questions/bugs/inconsistencies 14/02/2015 at 19:11 #69203
Danny252
Avatar
1458 posts
Online
" said:
" said:
I'm running through my West Hampstead 2015 timetable, and every train from Wellingborough is entering a minute late.

I have tried starting the timetable in easy mode and immediately saving it in order to get a 'clean' timetable, but they're still entering late. :(
Previously reported here on the Forum and logged on the issue tracker as #12191.
That bug only refers to trains entering at 00:00 and 00:00H, which I don't think is what John is referring to.

Log in to reply
Some questions/bugs/inconsistencies 14/02/2015 at 19:33 #69206
postal
Avatar
3822 posts
" said:
" said:
" said:
I'm running through my West Hampstead 2015 timetable, and every train from Wellingborough is entering a minute late.

I have tried starting the timetable in easy mode and immediately saving it in order to get a 'clean' timetable, but they're still entering late. :(
Previously reported here on the Forum and logged on the issue tracker as #12191.
That bug only refers to trains entering at 00:00 and 00:00H, which I don't think is what John is referring to.
Description of the bug reads:

"As per http://www.simsig.co.uk/index.php?option=com_kunena&view=topic&catid=57&id=38832&Itemid=0#66856 [^]

It does seem that from time to time trains are erroneously having 1 minute delays added to the entry time."

The further detail in the steps to reproduce refer to entries at the start of the TT but this is only a way for one of the core code developers to see what is happening. The actual description identifies the bug as generic.

"Always forgive your enemies -- nothing annoys them so much" - Oscar Wilde (16/10/1854 – 30/11/1900), Irish poet and playwright.
Log in to reply
Some questions/bugs/inconsistencies 14/02/2015 at 22:36 #69208
peterb
Avatar
394 posts
It's interesting the tests Peter Bennet has done - but look at my post #11.

I found that in Aston and Stafford at least, the issue of trains entering one minute late is present throughout a timetable, and is not exclusive to those entering specifically at 00:00.

I'd like to have it looked at again, under the premise that the behaviour Peter has found and that which I have found are one and the same bug.

Log in to reply