Upcoming Games


Full list
Add a game

Upcoming Events

2DXX Ilkley services at Esholt JN

You are here: Home > Forum > Simulations > Released > Leeds Northwest > 2DXX Ilkley services at Esholt JN

Page 1 of 1

2DXX Ilkley services at Esholt JN 29/06/2017 at 18:25 #96055
njimiller
Avatar
134 posts
Loader 4.6.4
Leeds Northwest Version 1.1
Timetable: 15/10/09 1.1.0

Running in ARS mode 2DXX Ilkley bound services at Esholt JN route towards Guiseley P2 rather P1. In the attached save this will happen when 2D30 is made ARS. The timetable for 2D30 was manually adjusted to specify P1 at Guiseley but this makes no difference.

Nick

Post has attachments. Log in to view them.
Log in to reply
2DXX Ilkley services at Esholt JN 29/06/2017 at 20:20 #96060
postal
Avatar
4872 posts
njimiller in post 96055 said:
Loader 4.6.4
Leeds Northwest Version 1.1
Timetable: 15/10/09 1.1.0

Running in ARS mode 2DXX Ilkley bound services at Esholt JN route towards Guiseley P2 rather P1. In the attached save this will happen when 2D30 is made ARS. The timetable for 2D30 was manually adjusted to specify P1 at Guiseley but this makes no difference.

Nick
Haven't got the sim so am speaking from theory rather than from examining the save. There may be an answer in the way that you amended the TT. As a start there are a couple of questions about the TT adjustment.

1) Was 2D30 already in sim when you adjusted the TT?
2) If it was in sim, did you adjust the TT through F2 or F4?

Reason for the questions is because of the way that the core code handles TTs. If the train is already in sim, then adjusting the TT through F4 does not change the TT for the train in sim, although if you save the TT then the adjustment will show next time the TT is run. Conversely, if you adjusted the TT through F2 then that should amend the TT for the train in sim but will not be saved to the file copy of the TT and will run to the unamended TT next time the sim is run.

So, if 2D30 was in sim and you adjusted the TT through F4, the train in sim still thinks it is due to P2 and will be routed there by the ARS.

If that isn't the answer someone else will be able to add their two penn'orth.

“In life, there is always someone out there, who won’t like you, for whatever reason, don’t let the insecurities in their lives affect yours.” – Rashida Rowe
Last edited: 29/06/2017 at 20:21 by postal
Reason: None given

Log in to reply
2DXX Ilkley services at Esholt JN 29/06/2017 at 20:27 #96061
Noisynoel
Avatar
989 posts
I've just run the save with no issue. I am running a newer version than everyone else but I havn't amended anything in that are between v1.1 & v1.2
Can someone running v1.1 please run the save and see what occurs.
Has anyone else found this issue. It hasn't been mentioned on the forum as yet

Noisynoel
Log in to reply
2DXX Ilkley services at Esholt JN 29/06/2017 at 20:44 #96062
JamesN
Avatar
1437 posts
Noisynoel in post 96061 said:
I've just run the save with no issue. I am running a newer version than everyone else but I havn't amended anything in that are between v1.1 & v1.2
Can someone running v1.1 please run the save and see what occurs.
Has anyone else found this issue. It hasn't been mentioned on the forum as yet
Loader 4.6.4
Sim 1.1

Unable to Reproduce; when 2D30 is made ARS it correctly routes the train towards the Down Ilkley Main.

EDIT I take that back...

http://imgur.com/a/T1sIx

Last edited: 29/06/2017 at 20:53 by JamesN
Reason: None given

Log in to reply
2DXX Ilkley services at Esholt JN 29/06/2017 at 21:06 #96064
njimiller
Avatar
134 posts
Which of course it does for me now too. However...

I've taken the same game and run it forward with 2D32 and the error is repeated. As 2D32 gets to Baildon ARS states 2V07 is already on the stretch of track and then once Guiseley P2 is clear then 2D32 routes towards P2. However - 2D32 routes towards P1 IF 2D33 is already occupying the track towards P2 - hence why I've collared signal 3948 to prevent this.

So - ARS will route 2DXX trains to P1 only as an alternative if P2 has a route set to it from Ilkley.

Nick

Post has attachments. Log in to view them.
Log in to reply
2DXX Ilkley services at Esholt JN 29/06/2017 at 21:09 #96065
Noisynoel
Avatar
989 posts
It looks like the timetable does not have a platform shown, hence it routes it incorrectly
Noisynoel
Log in to reply
2DXX Ilkley services at Esholt JN 29/06/2017 at 21:18 #96066
njimiller
Avatar
134 posts
In the first saved game I added P1 to 2D30's timetable but it made no difference. It still routed to P2. I know that can't be reproduced in that save as the route to P2 from Ilkley has just been set.
I will test it by altering a 2DXX timetable for one that hasn't already entered the sim.
Nick.

Last edited: 29/06/2017 at 21:19 by njimiller
Reason: None given

Log in to reply
2DXX Ilkley services at Esholt JN 29/06/2017 at 21:23 #96067
Noisynoel
Avatar
989 posts
If you amend a trains timetable via F2 after it has entered ARS "May" not work, hence the warning message when you do it
Noisynoel
Log in to reply
2DXX Ilkley services at Esholt JN 29/06/2017 at 23:15 #96068
JamesN
Avatar
1437 posts
#17563 on the bug tracker.
Log in to reply
2DXX Ilkley services at Esholt JN 30/06/2017 at 00:45 #96071
Sacro
Avatar
1125 posts
Noisynoel in post 96065 said:
It looks like the timetable does not have a platform shown, hence it routes it incorrectly
Platforms are not required to be given, trains shouldn't cross over unless told to.

Log in to reply
2DXX Ilkley services at Esholt JN 30/06/2017 at 07:15 #96073
njimiller
Avatar
134 posts
Thanks for the replies. Just to confirm I've tried this by editing the timetable of 2D32 before it had entered the sim by specifying P1 and adding Esholt Jn as a passing location. 2D32 waits for 2V07 to clear the line and then routes to P2. Ilkley bound 2VXX services correctly go via P1. As noted above, if a 2DXX service from Ilkley has already taken up the track towards P2, then the 2DXX service to Ilkley will go to P1.

Thanks
Nick

Post has attachments. Log in to view them.
Log in to reply
2DXX Ilkley services at Esholt JN 30/06/2017 at 09:52 #96074
Noisynoel
Avatar
989 posts
The bug your experiencing is caused by the TT not having P1 in it. However, it should in theory work 99% of the time, which probably explains why no one has found this issue up until now. For the sim to work 100% it requires P1 added to every train (yes I know they are not mandatory, I know they are not in the CIF, however, they are required by SimSig to guarantee success). I have sent an update to Geoff for release which will cause the sim to auto populate the platform field in the timetable. This will ensure it gets the correct route.
Noisynoel
Log in to reply
The following user said thank you: njimiller