Upcoming Games

Upcoming Events

17/11/2018 12:00:00
01/06/2019 12:00:00

Trains to/from Patchway stopped at red signals

You are here: Home > Forum > Simulations > Released > Newport > Trains to/from Patchway stopped at red signals

Page 1 of 1

Trains to/from Patchway stopped at red signals 09/07/2018 at 02:22 #110162
robfromcanada
Avatar
7 posts
Hi - I'm new to the Newport sim, and I'm having trouble with trains going to and from Patchway. For a train coming from Patchway, I give the slot by clicking signal 162 and the signal head turns white. All inbound trains except the first then get stopped at signal B118. Trains going to Patchway have the same problem, except they stop at signal B102 (I think it was). It seems as though the AI signaller at Bristol has fallen asleep at the switch...

This happens in both of the supplied midnight start timetables. Has anybody else run into this?

Thanks!

Log in to reply
Trains to/from Patchway stopped at red signals 09/07/2018 at 11:33 #110169
BarryM
Avatar
2028 posts
I found no problems with Patchway. Have you read the Newport manual? It is quite comprehensive. Patchway is mention in it.
https://www.simsig.co.uk/Wiki/Show?page=simulations:newport


Barry

Barry, Sydney, New South Wales, Australia
Last edited: 09/07/2018 at 11:41 by BarryM
Reason: None given

Log in to reply
The following user said thank you: robfromcanada
Trains to/from Patchway stopped at red signals 09/07/2018 at 15:38 #110171
robfromcanada
Avatar
7 posts
Yes, several times - there's a good chance I'm missing something simple so I wanted to be sure I had read everything a few times for plausible deniability. :)

The manual mentions the points, which I've verified are normal; I've even tried locking them normal and the problem persists. In any case there's no problem granting the slot. Signals B118 and B102 aren't even on the panel; those are the next signals in the direction of Patchway.

Log in to reply
Trains to/from Patchway stopped at red signals 09/07/2018 at 16:20 #110173
postal
Avatar
3454 posts
Firstly do you have TORR (Train Operated Route Release) enabled? It is one of the options you get when you are loading the sim? This should cancel the route once a train has passed the signal.

Then, whether you have TORR enabled or not, does S162 remain white after the passage of the first train? If you have TORR enabled, TORR may not be coded for this signal. Either way you need to cancel the route manually (depending on how you have F3 set up either right-click on the signal or right-click and select cancel route). Although the signal still shows white on the panel, on the ground the signal has reverted to R behind the train which is why you need to cancel the route, You can then reset the route and the next train should proceed normally. Similarly for the other signal giving you problems.

"The most costly of all follies is to believe passionately in the palpably not true. It is the chief occupation of mankind." - H. L. Mencken (12 September 1880 – 29 January 1956), American journalist.
Last edited: 09/07/2018 at 16:28 by postal
Reason: None given

Log in to reply
The following user said thank you: robfromcanada
Trains to/from Patchway stopped at red signals 10/07/2018 at 02:42 #110178
robfromcanada
Avatar
7 posts
TORR is disabled. I've cancelled signal 162 after the first train passes, and giving the slot again has no effect. I've also tried giving the slot with and without a route selected from signal 164, with and without the points at the end of the Down Goods locked normal, with and without a train standing at B118... no luck so far.

I should have thought to do this earlier, but have now attached a save. 6B14 is approaching from Patchway in this save, and will come to a stand at B118 in a few minutes.

Edit to add: I'll try it with TORR enabled in a day or two if I have a chance - no time tonight, I'm afraid.

Post has attachments. Log in to view them.
Last edited: 10/07/2018 at 02:43 by robfromcanada
Reason: None given

Log in to reply
Trains to/from Patchway stopped at red signals 10/07/2018 at 09:35 #110181
postal
Avatar
3454 posts
Well that's got me beat. Perhaps Karl (developer) can give us some advice.
"The most costly of all follies is to believe passionately in the palpably not true. It is the chief occupation of mankind." - H. L. Mencken (12 September 1880 – 29 January 1956), American journalist.
Log in to reply
Trains to/from Patchway stopped at red signals 10/07/2018 at 13:35 #110182
BarryM
Avatar
2028 posts
robfromcanada in post 110178 said:
TORR is disabled. I've cancelled signal 162 after the first train passes, and giving the slot again has no effect. I've also tried giving the slot with and without a route selected from signal 164, with and without the points at the end of the Down Goods locked normal, with and without a train standing at B118... no luck so far.

I should have thought to do this earlier, but have now attached a save. 6B14 is approaching from Patchway in this save, and will come to a stand at B118 in a few minutes.

Edit to add: I'll try it with TORR enabled in a day or two if I have a chance - no time tonight, I'm afraid.
I ran your save. I asked 6B14 to pass 162 at stop and it went on its merry way. I cancelled the routes from 162 to 196, then set the road again from 162 and the signals all cleared. I found no problems with the signals.

Barry

Barry, Sydney, New South Wales, Australia
Log in to reply
Trains to/from Patchway stopped at red signals 10/07/2018 at 16:56 #110183
robfromcanada
Avatar
7 posts
BarryM in post 110182 said:


I ran your save. I asked 6B14 to pass 162 at stop and it went on its merry way. I cancelled the routes from 162 to 196, then set the road again from 162 and the signals all cleared. I found no problems with the signals.

Barry
Did you have to ask 6B14 to pass signal B118 at danger? I have no problems clearing the signals - it's getting the trains to pass B118 that's not happening for me. Unless the solution is that they all have to be talked past B118, but that doesn't seem right.

Log in to reply
Trains to/from Patchway stopped at red signals 10/07/2018 at 17:56 #110184
headshot119
Avatar
2785 posts
robfromcanada in post 110183 said:
BarryM in post 110182 said:


I ran your save. I asked 6B14 to pass 162 at stop and it went on its merry way. I cancelled the routes from 162 to 196, then set the road again from 162 and the signals all cleared. I found no problems with the signals.

Barry
Did you have to ask 6B14 to pass signal B118 at danger? I have no problems clearing the signals - it's getting the trains to pass B118 that's not happening for me. Unless the solution is that they all have to be talked past B118, but that doesn't seem right.
I've had a look through the save you have posted, and something isn't right with B118 signal. I'm not sure how it's got into the state it's in, but I've modified the off sim logic to prevent it happening in the future.

Update 1.0.7 available via the updater.

You will most likely need to start a fresh game, I don't think your save will work.

"Platform 1 your Maesteg service. Platform 1A your Aberdare. Platform 2 your London!"
Log in to reply
The following users said thank you: postal, robfromcanada, BarryM
Trains to/from Patchway stopped at red signals 10/07/2018 at 19:50 #110186
robfromcanada
Avatar
7 posts
That's awesome, thanks so much!
Log in to reply
Trains to/from Patchway stopped at red signals 11/07/2018 at 05:29 #110191
robfromcanada
Avatar
7 posts
Had a chance to try it out tonight - works great, thank you very much!
Log in to reply
The following user said thank you: headshot119