Upcoming Games


Full list
Add a game

Upcoming Events

No events to display

We are not planning any more in-person events until the COVID-19 situation has improved.

Edinburgh v5 issues.

You are here: Home > Forum > Simulations > Released > Edinburgh > Edinburgh v5 issues.

Page 1 of 4

loader v5.3 issues. 27/07/2020 at 22:57 #130030
rodney30
Avatar
130 posts
Online
I noticed about two hours ago. so about 9pm that Edinburgh has been released as a loader version. So thank you to the team behind this.

I have noticed a couple of issues with the 2006 tt supplied with the sim.

First issue is 5A41 04:30 Craigentinny - Dundee which reverses in platfrom 1 at Edinburgh Waverley. On changing directions the train stays in the platform but the tt steps to the next location.

Second issue I have just had 5G24 enter at Hilton Junction, I granted the slot then went to set the route from EB674 to EB672 but it is saying route not available.

Sorry to raise these issues but thank you for a wonderful sim.

Last edited: 27/07/2020 at 22:58 by rodney30
Reason: None given

Log in to reply
The following user said thank you: Peter Bennet
loader v5.3 issues. 27/07/2020 at 23:25 #130031
Peter Bennet
Avatar
4840 posts
Online
There have been problems reported with 5A41 in the .exe but I thought that had been fixed (it was a core code problem of some sort).

Newburgh line fixed.

Peter

I identify as half man half biscuit - crumbs!
Log in to reply
loader v5.3 issues. 27/07/2020 at 23:30 #130033
postal
Avatar
4411 posts
rodney30 in post 130030 said:
I noticed about two hours ago. so about 9pm that Edinburgh has been released as a loader version. So thank you to the team behind this.

I have noticed a couple of issues with the 2006 tt supplied with the sim.

First issue is 5A41 04:30 Craigentinny - Dundee which reverses in platfrom 1 at Edinburgh Waverley. On changing directions the train stays in the platform but the tt steps to the next location.

Second issue I have just had 5G24 enter at Hilton Junction, I granted the slot then went to set the route from EB674 to EB672 but it is saying route not available.

Sorry to raise these issues but thank you for a wonderful sim.
The 5A41 is a known issue and is under investigation on Mantis. It was originally seen a long time a go then resolved but the core code changes to bring Loader v5 forward seem to have revived the problem.

The EB674 problem is new and has never occurred during the hundreds of hours (literally) of testing I have done on the sim. You can get the route if you set it from EB674 to EB672 before granting the slot from HJ7. Will be reported on Mantis when I finish typing this.

Thanks for the report. Please write up any further issues you find as well.

“In life, there is always someone out there, who won’t like you, for whatever reason, don’t let the insecurities in their lives affect yours.” – Rashida Rowe
Log in to reply
The following user said thank you: rodney30
loader v5.3 issues. 29/07/2020 at 08:04 #130091
manadude2
Avatar
184 posts
I see in the wiki v5.2 with a fix for the "route not available" bug was released yesterday, however I've seen no updates in Loader and I still have the issue.

It was actually released, yes? Loader says I have v5.0 of Edinburgh.

Log in to reply
loader v5.3 issues. 29/07/2020 at 08:26 #130093
Hap
Avatar
476 posts
Most likely that the developer has submitted the update yesterday and is just waiting to be pushed out and the details have been updated on the Wiki, it shouldn't be to far away.
Keep an eye out on the loader throughout the day for any updates.

HAP
Log in to reply
loader v5.3 issues. 29/07/2020 at 08:53 #130094
Peter Bennet
Avatar
4840 posts
Online
manadude2 in post 130091 said:
I see in the wiki v5.2 with a fix for the "route not available" bug was released yesterday, however I've seen no updates in Loader and I still have the issue.

It was actually released, yes? Loader says I have v5.0 of Edinburgh.
Although there was a v5.0 v5.1 should have been the first release but as Hap said I sent it yesterday for upload but then that needs Karl to be around to execute.
Wiki was updated when I sent it in the morning but then you found the Millerhill bug so it was delayed a bit while I fixed that.
Because I already have the latest version of the Sim I'm never quite sure what's been pushed and what's not. Can someone confirm the v numbers for the rest of the McSims? All should be v5.1 (except Cathcart which has not changed), though I'm not sure there was any difference between 5.0 and 5.1 outside of Edinburgh, in most cases, it was really an exercise in consistency.


Peter

I identify as half man half biscuit - crumbs!
Log in to reply
loader v5.3 issues. 29/07/2020 at 09:11 #130095
Dick
Avatar
297 posts
Online
They are currently all 5.0 except Cathcart which is 4.2
Log in to reply
The following user said thank you: Peter Bennet
loader v5.3 issues. 29/07/2020 at 10:38 #130096
manadude2
Avatar
184 posts
Peter Bennet in post 130094 said:
manadude2 in post 130091 said:
I see in the wiki v5.2 with a fix for the "route not available" bug was released yesterday, however I've seen no updates in Loader and I still have the issue.

It was actually released, yes? Loader says I have v5.0 of Edinburgh.
Although there was a v5.0 v5.1 should have been the first release but as Hap said I sent it yesterday for upload but then that needs Karl to be around to execute.
Wiki was updated when I sent it in the morning but then you found the Millerhill bug so it was delayed a bit while I fixed that.
Because I already have the latest version of the Sim I'm never quite sure what's been pushed and what's not. Can someone confirm the v numbers for the rest of the McSims? All should be v5.1 (except Cathcart which has not changed), though I'm not sure there was any difference between 5.0 and 5.1 outside of Edinburgh, in most cases, it was really an exercise in consistency.


Peter

Thanks for clarifying Peter. I wasn't sure if it was available and my Loader wasn't picking up the update, or it just wasn't put out for general release yet.

Last edited: 29/07/2020 at 10:48 by manadude2
Reason: None given

Log in to reply
loader v5.3 issues. 29/07/2020 at 11:18 #130098
Hap
Avatar
476 posts
Peter Bennet in post 130094 said:
manadude2 in post 130091 said:
I see in the wiki v5.2 with a fix for the "route not available" bug was released yesterday, however I've seen no updates in Loader and I still have the issue.

It was actually released, yes? Loader says I have v5.0 of Edinburgh.
Although there was a v5.0 v5.1 should have been the first release but as Hap said I sent it yesterday for upload but then that needs Karl to be around to execute.
Wiki was updated when I sent it in the morning but then you found the Millerhill bug so it was delayed a bit while I fixed that.
Because I already have the latest version of the Sim I'm never quite sure what's been pushed and what's not. Can someone confirm the v numbers for the rest of the McSims? All should be v5.1 (except Cathcart which has not changed), though I'm not sure there was any difference between 5.0 and 5.1 outside of Edinburgh, in most cases, it was really an exercise in consistency.


Peter
Peter, What I have is....

Cathcart - V4.2
CScot - V5.0
Cowlairs - V5.0
Edinburgh - V5.0 (pending update push)
Motherwell 4.5 Build 1
NE Scot - V5.0
Paisley - V5.0

Craig

HAP
Last edited: 29/07/2020 at 11:18 by Hap
Reason: None given

Log in to reply
The following user said thank you: Peter Bennet
loader v5.3 issues. 29/07/2020 at 19:46 #130123
ajax103
Avatar
836 posts
Not sure why but I've noticed a few signals that don't display any aspect even if a route is set from them, not sure if it's just me but I found the following signals not to display any aspect at:

EP624 which is the signal protecting the Up Berwick from Powderhall although you can set a route from EP624 to EP618, you don't get any aspect on EP624.

EN583 which is the signal at Carmondean Junction, again you can set a route to Bathgate yard but no aspect is shown on this signal.

EY657 which is the signal starter for the Down Platform Loop, you can set a route to EY661 but no aspect is shown, also EY655 which you have to unlock and use the ground frame to permit a movement to the Up Yard at Dalmeny, I've clicked on EY655 but no aspect seems to be shown.

EV426 which is the signal starter for the Up Platform Loop just past Dalgety Bay, you can set a route to Signal EV412 but no aspect is shown.

EB671 which is the signal at Ladybank Branch Loop which protects the Up/Down Newburgh from the Ladybank Branch Loop, again you can set a route towards Hilton Junction but you don't get any aspect at all.

Not sure why, maybe it's how it's done in real life I don't know. Hopefully someone here can help?

I'm using Loader 5.3, Edinburgh 5.2 and I've started with no timetable and on easy mode.

Last edited: 29/07/2020 at 19:54 by ajax103
Reason: None given

Log in to reply
loader v5.3 issues. 29/07/2020 at 19:55 #130125
peterb
Avatar
416 posts
Online
Ajax

I'd just wait for confirmation but they all look to be signals 'blank' by design to prevent reading across as they would usually be at red.

Log in to reply
loader v5.3 issues. 29/07/2020 at 20:05 #130128
manadude2
Avatar
184 posts
ajax103 in post 130123 said:
Not sure why but I've noticed a few signals that don't display any aspect even if a route is set from them, not sure if it's just me but I found the following signals not to display any aspect at:

EP624 which is the signal protecting the Up Berwick from Powderhall although you can set a route from EP624 to EP618, you don't get any aspect on EP624.

EN583 which is the signal at Carmondean Junction, again you can set a route to Bathgate yard but no aspect is shown on this signal.

EY657 which is the signal starter for the Down Platform Loop, you can set a route to EY661 but no aspect is shown, also EY655 which you have to unlock and use the ground frame to permit a movement to the Up Yard at Dalmeny, I've clicked on EY655 but no aspect seems to be shown.

EV426 which is the signal starter for the Up Platform Loop just past Dalgety Bay, you can set a route to Signal EV412 but no aspect is shown.

EB671 which is the signal at Ladybank Branch Loop which protects the Up/Down Newburgh from the Ladybank Branch Loop, again you can set a route towards Hilton Junction but you don't get any aspect at all.

Not sure why, maybe it's how it's done in real life I don't know. Hopefully someone here can help?

I'm using Loader 5.3, Edinburgh 5.2 and I've started with no timetable and on easy mode.
These signals are approach lit. They only light if a route is set TO them, or a train is in front of them.
@peterb is correct, these signals are normally unlit to prevent confusion.

Log in to reply
loader v5.3 issues. 29/07/2020 at 21:49 #130135
danners430
Avatar
79 posts
So my primary question now is this... Do you believe Edinbugger is ready for its first multiplayer session? I haven't been able to play it properly in singleplayer as of yet - it's just too big for me!
Log in to reply
Edinburgh v5 issues. 29/07/2020 at 22:12 #130142
swiftaw
Avatar
135 posts
Also, as I side note, now that it has been released it needs to be added back in to the Chaining Diagram.
Log in to reply
Edinburgh v5 issues. 29/07/2020 at 22:21 #130143
ajax103
Avatar
836 posts
Just a bit of a tip on 5A41, I know it's a reported issue that it enters Craigentinny No2 and that it doesn't step up when routed into any platform, indeed it tends to stop at every passing point even with the passing option selected and it doesn't step up oncew it first arrives at Edinburgh Waverley but there is a solution that does work for the default 2006 timetable.

Simply ensure it enters at Craigintenny East Depot and have the next location as Niddre West Junction, yes it means that the reversal at Platform 1/19 isn't done BUT it does step up at each location as it's meant to and reverses correctly on it's next arrival at Edinburgh Waverley, it then carries out the crew change as booked then once it's ready it actually does step up and depart on time.

I don't know the permitted routes in real life nor do I know how often the East Depot Line is used but I just tried the above and it worked as a dream.

I just thought I mention it, by the way if anyone local can advise but how often and are there any restrictions on services using the above line or is it just like Bounds Green has two entrances that can be used?

Log in to reply
Edinburgh v5 issues. 29/07/2020 at 23:22 #130150
DaveHarries
Avatar
1064 posts
danners430 in post 130135 said:
So my primary question now is this... Do you believe Edinbugger is ready for its first multiplayer session? I haven't been able to play it properly in singleplayer as of yet - it's just too big for me!

Would be good to have a large McSim chain: hopefully everything would work OK therein.

Dave

Log in to reply
Edinburgh v5 issues. 29/07/2020 at 23:22 #130151
postal
Avatar
4411 posts
ajax103 in post 130143 said:
Just a bit of a tip on 5A41, I know it's a reported issue that it enters Craigentinny No2 and that it doesn't step up when routed into any platform, indeed it tends to stop at every passing point even with the passing option selected and it doesn't step up oncew it first arrives at Edinburgh Waverley but there is a solution that does work for the default 2006 timetable.

Simply ensure it enters at Craigintenny East Depot and have the next location as Niddre West Junction, yes it means that the reversal at Platform 1/19 isn't done BUT it does step up at each location as it's meant to and reverses correctly on it's next arrival at Edinburgh Waverley, it then carries out the crew change as booked then once it's ready it actually does step up and depart on time.

I don't know the permitted routes in real life nor do I know how often the East Depot Line is used but I just tried the above and it worked as a dream.

I just thought I mention it, by the way if anyone local can advise but how often and are there any restrictions on services using the above line or is it just like Bounds Green has two entrances that can be used?
Much easier to run it to TT then when ARS sets the route from the first call at the Waverley to Abbeyhill Jn use F2 to abandon the TT; when it reaches Abbeyhill Jn use F2 to reinstate the TT. Everything runs tickety-boo after that.

“In life, there is always someone out there, who won’t like you, for whatever reason, don’t let the insecurities in their lives affect yours.” – Rashida Rowe
Log in to reply
Edinburgh v5 issues. 29/07/2020 at 23:34 #130152
danners430
Avatar
79 posts
DaveHarries in post 130150 said:
danners430 in post 130135 said:
So my primary question now is this... Do you believe Edinbugger is ready for its first multiplayer session? I haven't been able to play it properly in singleplayer as of yet - it's just too big for me!

Would be good to have a large McSim chain: hopefully everything would work OK therein.

Dave
Oh, I've been making plans for a while... Long term plan is to try and squeeze a modern, EGIP, timetable into the old layout that the sim currently uses, but even an older era would be interesting (if hard work)!

Last edited: 29/07/2020 at 23:34 by danners430
Reason: Forgot quote

Log in to reply
The following user said thank you: markt
Edinburgh v5 issues. 30/07/2020 at 00:13 #130153
bill_gensheet
Avatar
580 posts
A CSCOT/EDIN/MOTH set of compatible(#) 1993 timetables are imminent...


#famous last words - you lot will break them in no time :-)

Bill

Log in to reply
Edinburgh v5 issues. 30/07/2020 at 00:25 #130154
Hap
Avatar
476 posts
danners430 in post 130152 said:
DaveHarries in post 130150 said:
danners430 in post 130135 said:
So my primary question now is this... Do you believe Edinbugger is ready for its first multiplayer session? I haven't been able to play it properly in singleplayer as of yet - it's just too big for me!

Would be good to have a large McSim chain: hopefully everything would work OK therein.

Dave
Oh, I've been making plans for a while... Long term plan is to try and squeeze a modern, EGIP, timetable into the old layout that the sim currently uses, but even an older era would be interesting (if hard work)!
That's not gonna work. Track layout changes and line speed changes won't give you a decent representation of the current real life line. Also QST platforms aren't as they are now for 380/385s in multiple formations.
Some of these changes are the uplifting of the DGL at Greenhill upper, and a new slip from the main line to the Down Branch/Down Perth. line speed raised.
Larbert Down side lifted and made into a DPL. Up side a CE siding. Colour light signalling on all areas of DBL except the Up home and Down Section.

Since the EMUs have been fully integrated onto the lines they now work, all the timings have been made to take into account 1. DMUs running and 2. HST running. The sim(s) as it stands, doesn't represent this and Edinburgh most definitely won't work with anything modern. A full station refurb is needed. Edinburgh sim represents pre-platform changes circa 2006-2007. so even a 2009 TT wouldn't work as platforms 20/1/10 became aren't there and AC was introduced onto the bays at the West end of the station. Then you have the Bathgate line and remodelling of Newbridge junction and double tracking and extended control of Edinburgh box...

So basically if you want a working TT, it's going to have to be pre-2006.

HAP
Log in to reply
Edinburgh v5 issues. 30/07/2020 at 00:36 #130155
Hap
Avatar
476 posts
ajax103 in post 130143 said:
Just a bit of a tip on 5A41, I know it's a reported issue that it enters Craigentinny No2 and that it doesn't step up when routed into any platform, indeed it tends to stop at every passing point even with the passing option selected and it doesn't step up oncew it first arrives at Edinburgh Waverley but there is a solution that does work for the default 2006 timetable.

Simply ensure it enters at Craigintenny East Depot and have the next location as Niddre West Junction, yes it means that the reversal at Platform 1/19 isn't done BUT it does step up at each location as it's meant to and reverses correctly on it's next arrival at Edinburgh Waverley, it then carries out the crew change as booked then once it's ready it actually does step up and depart on time.

I don't know the permitted routes in real life nor do I know how often the East Depot Line is used but I just tried the above and it worked as a dream.

I just thought I mention it, by the way if anyone local can advise but how often and are there any restrictions on services using the above line or is it just like Bounds Green has two entrances that can be used?
The east line is used often, BUT, if going around the Sub lines, Diesel only.
One regular use of the East line was to turn HSts at Newcraighall by using the triangle.

Where the hollow track is on sim at the East Line Depot... that hollow spur is the line to the Wheel Lathe and 5 other sidings where XC stable their voyagers. They have to normally run through the depot wash road/slip road and out via roads 1-4. EDB XC crews do sign the sub. IIRC - There would be a 8 car 220 arrive and split. One for Glasgow which was leading, and the other headed down South but had to be turned, so detached and ran round the Sub lines and back in, which in return cleared the platform for another SB service, which I think was a GN.

HAP
Log in to reply
Edinburgh v5 issues. 30/07/2020 at 07:41 #130161
ajax103
Avatar
836 posts
Hap in post 130155 said:


The east line is used often, BUT, if going around the Sub lines, Diesel only.
One regular use of the East line was to turn HSts at Newcraighall by using the triangle.

Where the hollow track is on sim at the East Line Depot... that hollow spur is the line to the Wheel Lathe and 5 other sidings where XC stable their voyagers. They have to normally run through the depot wash road/slip road and out via roads 1-4. EDB XC crews do sign the sub. IIRC - There would be a 8 car 220 arrive and split. One for Glasgow which was leading, and the other headed down South but had to be turned, so detached and ran round the Sub lines and back in, which in return cleared the platform for another SB service, which I think was a GN.
Ahh okay, I was aware that most services use No1 to No4 to enter/exit but wasn't sure how much the entrance/exit at the Newcraighall end was used.

postal in post 130151 said:
ajax103 in post 130143 said:
Just a bit of a tip on 5A41, I know it's a reported issue that it enters Craigentinny No2 and that it doesn't step up when routed into any platform, indeed it tends to stop at every passing point even with the passing option selected and it doesn't step up oncew it first arrives at Edinburgh Waverley but there is a solution that does work for the default 2006 timetable.

Simply ensure it enters at Craigintenny East Depot and have the next location as Niddre West Junction, yes it means that the reversal at Platform 1/19 isn't done BUT it does step up at each location as it's meant to and reverses correctly on it's next arrival at Edinburgh Waverley, it then carries out the crew change as booked then once it's ready it actually does step up and depart on time.

I don't know the permitted routes in real life nor do I know how often the East Depot Line is used but I just tried the above and it worked as a dream.

I just thought I mention it, by the way if anyone local can advise but how often and are there any restrictions on services using the above line or is it just like Bounds Green has two entrances that can be used?
Much easier to run it to TT then when ARS sets the route from the first call at the Waverley to Abbeyhill Jn use F2 to abandon the TT; when it reaches Abbeyhill Jn use F2 to reinstate the TT. Everything runs tickety-boo after that.
Well yes that is one option available.

Log in to reply
Edinburgh v5 issues. 30/07/2020 at 11:15 #130167
bill_gensheet
Avatar
580 posts
Hap in post 130155 said:


The east line is used often, BUT, if going around the Sub lines, Diesel only.
One regular use of the East line was to turn HSts at Newcraighall by using the triangle.

Where the hollow track is on sim at the East Line Depot... that hollow spur is the line to the Wheel Lathe and 5 other sidings where XC stable their voyagers. They have to normally run through the depot wash road/slip road and out via roads 1-4. EDB XC crews do sign the sub. IIRC - There would be a 8 car 220 arrive and split. One for Glasgow which was leading, and the other headed down South but had to be turned, so detached and ran round the Sub lines and back in, which in return cleared the platform for another SB service, which I think was a GN.
Going back a few more years, I believe that 1 & 2 were arrival lines (why there is no slot on them) while 3 & 4 were normally departures (hence slots) or further back were departure only.
4 is/was also short so could only take locos or short passenger trains without fouling elsewhere.
In terms of access to facilities, the only washer was on 1, 1 & 2 had direct access to the east (ie not via a shed) but only 3 & 4 accessed the sheds/sidings 1 - 23.
As such I take operation to have been:
Arrive into 1 for a wash / fuel
Arrive into 2 to fuel/water or access inspection shed
Arrive into 3 to go direct to sidings
Internal shunts from east of 1 & 2 via 3 to sidings / sheds (maybe the sim should delay slot requests at times ?)
Depart from 3 (or 4 for short trains if busy)
Arrive /depart 4 for light engines


For current images:
https://plumbloco.smugmug.com/Trains/BLS-TPE-Clyde-Race-TrackerTour/i-5tqMKnN
Photos from a railtour, showing the newer washer on line 3.

Bill

Log in to reply
The following user said thank you: Hap
Edinburgh v5 issues. 30/07/2020 at 11:26 #130168
sloppyjag
Avatar
474 posts
Can't see this mentioned elsewhere with regard to V5 release but ARS does not seem to operate the non-stop button at Kingsknowe LC. Manual seems to suggest it should and works perfectly at Kirknewton LC.

Not a biggy but annoying nonetheless.

Planotransitophobic!
Log in to reply
Edinburgh v5 issues. 30/07/2020 at 12:06 #130169
Steamer
Avatar
3349 posts
Hap in post 130154 said:

That's not gonna work. Track layout changes and line speed changes won't give you a decent representation of the current real life line. Also QST platforms aren't as they are now for 380/385s in multiple formations.
Some of these changes are the uplifting of the DGL at Greenhill upper, and a new slip from the main line to the Down Branch/Down Perth. line speed raised.
Larbert Down side lifted and made into a DPL. Up side a CE siding. Colour light signalling on all areas of DBL except the Up home and Down Section.

Since the EMUs have been fully integrated onto the lines they now work, all the timings have been made to take into account 1. DMUs running and 2. HST running.
The platform lengths on CScot match those given in the current sectional appendix. The lower speed limit for the Branch line at Greenhill (40 on sim vice 70 in real life) isn't brilliant but can be lived with. Everything else you've listed is more cosmetic- while not fully accurate, it shouldn't functionally affect the running of a modern TT, unless there's a real show-stopper that I've missed?

Agreed that a modern Edinburgh TT isn't remotely possible.

"Don't stress/ relax/ let life roll off your backs./ Except for death and paying taxes/ everything in life.../ is only for now." (Avenue Q)
Last edited: 30/07/2020 at 13:40 by Steamer
Reason: None given

Log in to reply