Upcoming Games


Full list
Add a game

Upcoming Events

No events to display

We are not planning any more in-person events until the COVID-19 situation has improved.

Issue with Leeds Ardsley

You are here: Home > Forum > Simulations > Released > Doncaster (North) > Issue with Leeds Ardsley

Page 1 of 1

Issue with Leeds Ardsley 30/11/2021 at 08:49 #142626
Guts
Avatar
404 posts
I've put this fault in this thread because I've never had this issue before when chaining Ardsley, but this issue has occurred when chaining with Doncaster North

I've started a big chain with 6 Sim including Leeds Ardsley and Doncaster North.

Doncaster has dropped out of the chain due to 'Lost License'. I paused to restart Donny, but in the process, Leeds Ardsley didn't pause, and had to be manually paused outside the chain though it's still connected to all the others.

I've restarted Donny and reconnected it to the chain, and I noticed the Chaining ports were showing incorrectly for Ardsley and Doncaster North. [Pic uploaded]

I unpaused the chain and Leeds Ardsley did not start back up with the rest of the chain. I'm in the process of disconnecting and then reconnecting Ardsley to rectify the fault. I've saved both Sims first. (Doncaster save is after reload after lost licence)

I'll update with the outcome.


Post has attachments. Log in to view them.
Log in to reply
Issue with Leeds Ardsley 30/11/2021 at 10:26 #142627
Steamer
Avatar
3684 posts
Which order did you chain the simulations in? If Leeds A is dependant on Donny N for time synchronisation, then I'm pretty sure Donny N dropping out will cause Leeds A to lose time sync regardless of any other chain connections.
"Don't stress/ relax/ let life roll off your backs./ Except for death and paying taxes/ everything in life.../ is only for now." (Avenue Q)
Log in to reply
The following user said thank you: Hap
Issue with Leeds Ardsley 30/11/2021 at 10:28 #142628
Hap
Avatar
665 posts
What is the other one sim that you connected that isn't shown on you picture?
HAP
Last edited: 30/11/2021 at 10:30 by Hap
Reason: Typo fixes

Log in to reply
Issue with Leeds Ardsley 30/11/2021 at 11:09 #142629
Hap
Avatar
665 posts
I've connected Donny North, LA, L E/W and York N/S to West Yorkshire.
Then I've connected all the other fringes together, with the last connection being Leeds N/W to Leeds E/W.

West Yorkshire is the "host" sim and I've ran through an hour with all sims working in tandem with each other.




Post has attachments. Log in to view them.
HAP
Log in to reply
Issue with Leeds Ardsley 30/11/2021 at 11:57 #142630
Guts
Avatar
404 posts
I connected Leeds E/W, York North/South, West Yorkshire, Donny North, Leeds NW, Leeds Ardsley in that order.

Leeds E/W was the host sim

Leeds <- York N/S
<- West Yorkshire
<- Leeds NW
<- Leeds Ardsley

York N/S -> Leeds E/W
<- West Yorkshire
<- Donny North

West Yorkshire -> Leeds E/W
-> York N/S
<- Donny North
<- Leeds Ardsley

Donny North -> York N/S
-> West Yorkshire
<- Leeds Ardsley (initially then switched -> on restart)

Leeds NW -> Leeds E/W

Leeds Ardsley -> Leeds E/W
-> West Yorkshire
-> Donny North - (initially then switched <- on Donny restart)

It's been continuing to work currently since the restart.

Log in to reply
Issue with Leeds Ardsley 30/11/2021 at 12:57 #142633
Albert
Avatar
1266 posts
Online
Guts in post 142626 said:

I've restarted Donny and reconnected it to the chain, and I noticed the Chaining ports were showing incorrectly for Ardsley and Doncaster North. [Pic uploaded]
The "From" ports are different from the "To" ports. This is normal (and also happens for players connecting to multiplayer games.)

In every connection there is a host with a configured port number, which you need so the sims can find each other. The other sim acts as client, which means they get a port number assigned by their OS (in a local network) or router (if connecting over the internet.)
It is done this way because this means only the host needs to do port forwarding, clients don't need to.

So in your case Leeds Ardsley uses 50507 to accept connections from players and was assigned 55556 by your OS to connect to West Yorkshire. Doncaster North uses 50513 to accept connections from Leeds Ardsley & players and was assigned 56417 to connect to West Yorkshire.

AJP in games
Last edited: 30/11/2021 at 12:58 by Albert
Reason: None given

Log in to reply
The following user said thank you: Guts
Issue with Leeds Ardsley 30/11/2021 at 17:44 #142651
Steamer
Avatar
3684 posts
Guts in post 142630 said:
I connected Leeds E/W, York North/South, West Yorkshire, Donny North, Leeds NW, Leeds Ardsley in that order.

Donny North -> York N/S
-> West Yorkshire
<- Leeds Ardsley (initially then switched -> on restart)
Yep, that's your issue. Assuming you left 'Synchronise time' ticked on every occasion, then connecting Leeds Ardsley to Doncaster North after you connected Leeds A to Leeds E/W means that Leeds A was looking to Donny North for the time. Once Donny N went down, Leeds A lost its time reference.

One way to simplify it might be to set up a bare-bones set of chains to link all the simulations to Leeds E/W with synchronise time ticked, then make all the fill-in connections with it unticked.

So connect Leeds N/W-> Leeds E/W, York N/S-> Leeds E/W, Leeds A-> Leeds E/W, West Y-> Leeds E/W, Donny N-> Leeds A all with 'synchronise time' ticked, thus getting all sims running on the same time. Then, make all the other connections with 'synchronise time' unticked. This should also make it easier to avoid creating a loop of simulations all looking to each other for the time.

"Don't stress/ relax/ let life roll off your backs./ Except for death and paying taxes/ everything in life.../ is only for now." (Avenue Q)
Last edited: 30/11/2021 at 17:45 by Steamer
Reason: None given

Log in to reply
Issue with Leeds Ardsley 01/12/2021 at 21:19 #142698
Guts
Avatar
404 posts
Steamer in post 142651 said:
Guts in post 142630 said:
I connected Leeds E/W, York North/South, West Yorkshire, Donny North, Leeds NW, Leeds Ardsley in that order.

Donny North -> York N/S
-> West Yorkshire
<- Leeds Ardsley (initially then switched -> on restart)
Yep, that's your issue. Assuming you left 'Synchronise time' ticked on every occasion, then connecting Leeds Ardsley to Doncaster North after you connected Leeds A to Leeds E/W means that Leeds A was looking to Donny North for the time. Once Donny N went down, Leeds A lost its time reference.

One way to simplify it might be to set up a bare-bones set of chains to link all the simulations to Leeds E/W with synchronise time ticked, then make all the fill-in connections with it unticked.

So connect Leeds N/W-> Leeds E/W, York N/S-> Leeds E/W, Leeds A-> Leeds E/W, West Y-> Leeds E/W, Donny N-> Leeds A all with 'synchronise time' ticked, thus getting all sims running on the same time. Then, make all the other connections with 'synchronise time' unticked. This should also make it easier to avoid creating a loop of simulations all looking to each other for the time.
I did this, as in Leeds Ardsley, to Leeds E/W with Donny N connected to Leeds Ardsley, and when the lost licence occurred again (yep forget to lock the licence) the same thing occurred. Everything paused but Leeds Ardsley kept going while still connected to Leeds E/W and West Yorkshire.

Log in to reply
Issue with Leeds Ardsley 01/12/2021 at 21:51 #142699
Steamer
Avatar
3684 posts
Guts in post 142698 said:
Steamer in post 142651 said:
Guts in post 142630 said:
I connected Leeds E/W, York North/South, West Yorkshire, Donny North, Leeds NW, Leeds Ardsley in that order.

Donny North -> York N/S
-> West Yorkshire
<- Leeds Ardsley (initially then switched -> on restart)
Yep, that's your issue. Assuming you left 'Synchronise time' ticked on every occasion, then connecting Leeds Ardsley to Doncaster North after you connected Leeds A to Leeds E/W means that Leeds A was looking to Donny North for the time. Once Donny N went down, Leeds A lost its time reference.

One way to simplify it might be to set up a bare-bones set of chains to link all the simulations to Leeds E/W with synchronise time ticked, then make all the fill-in connections with it unticked.

So connect Leeds N/W-> Leeds E/W, York N/S-> Leeds E/W, Leeds A-> Leeds E/W, West Y-> Leeds E/W, Donny N-> Leeds A all with 'synchronise time' ticked, thus getting all sims running on the same time. Then, make all the other connections with 'synchronise time' unticked. This should also make it easier to avoid creating a loop of simulations all looking to each other for the time.
I did this, as in Leeds Ardsley, to Leeds E/W with Donny N connected to Leeds Ardsley, and when the lost licence occurred again (yep forget to lock the licence) the same thing occurred. Everything paused but Leeds Ardsley kept going while still connected to Leeds E/W and West Yorkshire.
That's odd- was 'sync time' definitely unticked for any other connections made from Leeds A?

"Don't stress/ relax/ let life roll off your backs./ Except for death and paying taxes/ everything in life.../ is only for now." (Avenue Q)
Log in to reply
Issue with York North/South 01/12/2021 at 22:13 #142702
Guts
Avatar
404 posts
I don't know if this has been reported. There's a TC SOWC on Donny N in York North/South, but being actually clear on Donny North

In the first pic you see York North/South with the TC and the F11 panel showing T154 with an occupancy of 3, T154B (not shown) has an occupancy of 2 while T154B1 & T154B2 show a zero occupancy.

The second pic is of Donny North, showing 4R04 long gone from the fringe with York North/South

I have to note that York S868 was previously showing danger and wasn't clearing, so I got 4R04 to pass 868 at danger.

I don't whats causing the TCF as nothing has been announced.



Post has attachments. Log in to view them.
Last edited: 01/12/2021 at 22:44 by headshot119
Reason: Moved chaining issues all into one thread

Log in to reply
Issue with Leeds Ardsley 01/12/2021 at 22:52 #142705
Albert
Avatar
1266 posts
Online
It might be an issue with the chaining data as T154B is called TSH154AB on Doncaster North for reasons that aren't obvious to me.

Did you route any trains across the fringe before 4R04? That signal 868 didn't clear suggests that either something went wrong when chaining (in which case it would have been red from the start) or a previous train got the TCs across the fringe in an unusual state. If there was a previous train, do you remember whether it came from the main line or from Heck GF?

AJP in games
Log in to reply
Issue with Leeds Ardsley 01/12/2021 at 22:59 #142706
headshot119
Avatar
4230 posts
Albert in post 142705 said:
It might be an issue with the chaining data as T154B is called TSH154AB on Doncaster North for reasons that aren't obvious to me.

Did you route any trains across the fringe before 4R04? That signal 868 didn't clear suggests that either something went wrong when chaining (in which case it would have been red from the start) or a previous train got the TCs across the fringe in an unusual state. If there was a previous train, do you remember whether it came from the main line or from Heck GF?
The name of an entity displayed on an individual simulations isn't relevant to chaining, there's a second identifier which normal users can't see which identifies a particular entity between two simulations.

In this case the Doncaster North simulation shows T154A/B as a combined track circuit, York North South shows you the individual sections ie A / B separate.

I wasn't able to reproduce this in my own testing, I've logged Mantis 35089 for investigation by another tester or developer. Though given this whole thread revolves around a desynced chain session, I can't help but wonder if that is the root cause of the issue.

"Passengers for New Lane, should be seated in the rear coach of the train " - Opinions are my own and not those of my employer
Last edited: 01/12/2021 at 23:03 by headshot119
Reason: Edit for clarity

Log in to reply
The following user said thank you: Hap
Issue with Leeds Ardsley 02/12/2021 at 19:54 #142716
Guts
Avatar
404 posts
Steamer in post 142699 said:
Guts in post 142698 said:
Steamer in post 142651 said:
Guts in post 142630 said:
I connected Leeds E/W, York North/South, West Yorkshire, Donny North, Leeds NW, Leeds Ardsley in that order.

Donny North -> York N/S
-> West Yorkshire
<- Leeds Ardsley (initially then switched -> on restart)
Yep, that's your issue. Assuming you left 'Synchronise time' ticked on every occasion, then connecting Leeds Ardsley to Doncaster North after you connected Leeds A to Leeds E/W means that Leeds A was looking to Donny North for the time. Once Donny N went down, Leeds A lost its time reference.

One way to simplify it might be to set up a bare-bones set of chains to link all the simulations to Leeds E/W with synchronise time ticked, then make all the fill-in connections with it unticked.

So connect Leeds N/W-> Leeds E/W, York N/S-> Leeds E/W, Leeds A-> Leeds E/W, West Y-> Leeds E/W, Donny N-> Leeds A all with 'synchronise time' ticked, thus getting all sims running on the same time. Then, make all the other connections with 'synchronise time' unticked. This should also make it easier to avoid creating a loop of simulations all looking to each other for the time.
I did this, as in Leeds Ardsley, to Leeds E/W with Donny N connected to Leeds Ardsley, and when the lost licence occurred again (yep forget to lock the licence) the same thing occurred. Everything paused but Leeds Ardsley kept going while still connected to Leeds E/W and West Yorkshire.
That's odd- was 'sync time' definitely unticked for any other connections made from Leeds A?
No, because I generally start them all up and them connect them together after. Just enables me to look at the ports before I connect.

Log in to reply
Issue with Leeds Ardsley 02/12/2021 at 20:13 #142717
Guts
Avatar
404 posts
Nothing went through before 4R04. 868, just refused to clear.

It's happened again with the 2nd train through. Before I send the train I cancelled and then reconnect Donny with York North/South and 868 clear to a proceed aspect.

I'm going to send the only saves for before and after the 2nd train, 6E72.

Post has attachments. Log in to view them.
Log in to reply