Upcoming Games


Full list
Add a game

Upcoming Events

Who's Online

geswedey, Mattyq, Meld, pedroathome, PN40, sloppyjag (6 users seen recently)

Trains not entering from depots

You are here: Home > Forum > Simulations > Released > LTS > Trains not entering from depots

Page 1 of 1

Trains not entering from depots 15/06/2015 at 00:41 #73373
Muzer
Avatar
667 posts
I'm sure there was a thread about this before, but I can't find it. To recap, there are sometimes issues with trains entering from depots.

When SimSig crashed (a wine issue, I believe) last, I restored from the last snapshot. However, upon loading of the snapshot, the trains don't enter, even though their delay is such that they should enter early (this is true for both trains, maybe not a coincidence?). I thought you'd like to see this snapshot for debugging purposes. The trains in question are 5J19 at East Ham EMU Depot, and 5D05 at Shoeburyness Depot (Up).

(Any tips of how I can unjam both these depots in this game and force these trains to enter would also be appreciated; I've tried changing the delays, to no apparent effect.)

Post has attachments. Log in to view them.
Log in to reply
Trains not entering from depots 15/06/2015 at 01:29 #73374
Tempest Malice
Avatar
76 posts
I think I've mentioned this before in the main sims released thread but it hasn't been noticed yet. I'll just add a link as my previous message was quite long; but to summarise my findings on this bug. Saving after the depot interposes a TD but before a train enters 3 minutes later, and then loading the save, is what jams it up; at east ham down end you can cancel the TD and re interpose the same ID to get train to enter, at Shoeburyness as it uses queue berths you can't control them yourself so it's now blocked until the bug is fixed.
Last edited: 15/06/2015 at 01:29 by Tempest Malice
Log in to reply
The following user said thank you: Gwasanaethau
Trains not entering from depots 15/06/2015 at 03:14 #73382
Muzer
Avatar
667 posts
Cheers for the tip. I manually edited the save to get rid of the TD from the queue berth, so it's all sorted now
Log in to reply
Trains not entering from depots 15/06/2015 at 03:18 #73383
Tempest Malice
Avatar
76 posts
Did the missing trains from shoeburyness enter or did it just resume with the next entries after them?, if the missing trains did eventually enter then I might have to have a go at trying to edit my save.
Log in to reply
Trains not entering from depots 15/06/2015 at 03:22 #73384
Muzer
Avatar
667 posts
It did enter after about another minute. It even automatically recalculated the delay value to one that meant it entered after the game started.
Log in to reply
The following users said thank you: Tempest Malice, Gwasanaethau
Trains not entering from depots 20/06/2015 at 00:31 #73540
Gwasanaethau
Avatar
452 posts
To add to this: I had a couple of trains blocking the entrances without saving and reloading. At the point the trains blocked, I was running the sim at half-speed, could that have something to do with it too? This was running on loader 4.5.1 and sim version 1.0 (i.e. the one immediately prior to the update released yesterday (UTC)).

5Y15 blocked Shoeburyness London End, and 5N03 blocked East Ham EMUD 1019 (down direction). The remedies mentioned above fixed the problem and the trains entered promptly afterwards.

Log in to reply
Trains not entering from depots 30/07/2019 at 17:06 #119753
Gwasanaethau
Avatar
452 posts
Just to confirm: this is still occurring on loader 4.14 and sim 1.7…
Log in to reply
Trains not entering from depots 07/10/2019 at 09:48 #120782
Giantray
Avatar
215 posts
I am having the same issue when saving with routes set for trains from depots. When reloading the saved sim the trains are not in the train list (F2) with routes set. Most annoying as it ruins a saved session. My loader is up to date and I only just purchased a license for LTS the other day.
Professional Railwayman since 1981. Railway Historian (SER, LCDR)
Log in to reply
Trains not entering from depots 07/10/2019 at 09:57 #120783
jc92
Avatar
2695 posts
I think this is a core code issue with the way the simulation handles trains which haven't entered but are queued to as you get a similar problem although not quite the same for trains entering from Ashburys.
Log in to reply
Trains not entering from depots 07/10/2019 at 16:19 #120799
postal
Avatar
3875 posts
Giantray in post 120782 said:
I am having the same issue when saving with routes set for trains from depots. When reloading the saved sim the trains are not in the train list (F2) with routes set. Most annoying as it ruins a saved session. My loader is up to date and I only just purchased a license for LTS the other day.
Are the trains due to enter greyed out in F4 (Timetable)? If so you might be able to force the entry by highlighting the train and clicking on the Mark (Un)entered button.

"In the fight between you and the world, back the world." - Frank Zappa (21/12/1940 – 4/12/1993) , American multi-instrumentalist musician, composer, and bandleader.
Log in to reply
Trains not entering from depots 09/10/2019 at 10:08 #120843
Giantray
Avatar
215 posts
The trains aren't greyed out in the timetable.
Professional Railwayman since 1981. Railway Historian (SER, LCDR)
Log in to reply
The following user said thank you: postal