Upcoming Games

No games to display

Add a game

Upcoming Events

08/09/2018 11:30:00
17/11/2018 12:00:00
01/06/2019 12:00:00

Who's Online

Which version is correct please

You are here: Home > Forum > General > General questions, comments, and issues > Which version is correct please

Page 1 of 1

Which version is correct please 11/04/2018 at 20:38 #107469
northroad
Avatar
741 posts
Looking at all the recent updates which seem to be coming thick and fast these days can someone tell me which is the correct version for the loader and it's connected items.
Currently for me if I open the loader it is showing version 4.6.12 but if you click on check for updates it is showing version 4.6.9.0. Very confusing.

Geoff

Never apologise son, it's a sign of weakness (John Wayne)
Log in to reply
Which version is correct please 11/04/2018 at 20:42 #107470
headshot119
Avatar
2723 posts
northroad in post 107469 said:
Looking at all the recent updates which seem to be coming thick and fast these days can someone tell me which is the correct version for the loader and it's connected items.
Currently for me if I open the loader it is showing version 4.6.12 but if you click on check for updates it is showing version 4.6.9.0. Very confusing.

Geoff
Because your loader is at version 4.6.12 (which is the latest). And your refresher is at 4.6.9.0 (which is also the latest). The two programs are totally separate in terms of version numbers.

"Platform 1 your Maesteg service. Platform 1A your Aberdare. Platform 2 your London!"
Log in to reply
Which version is correct please 11/04/2018 at 20:58 #107472
northroad
Avatar
741 posts
As I understand things, if I update the loader as and when to the next version 4.6.13, it will be done via the loader. So how do I keep up with any updates for the Update. Surely that is also done via the loader and therefore it is connected and should therefore show the same version number.

Geoff

Never apologise son, it's a sign of weakness (John Wayne)
Last edited: 11/04/2018 at 20:59 by northroad
Reason: None given

Log in to reply
Which version is correct please 11/04/2018 at 21:03 #107473
headshot119
Avatar
2723 posts
northroad in post 107472 said:
As I understand things, if I update the loader as and when to the next version 4.6.13, it will be done via the loader. So how do I keep up with any updates for the Update. Surely that is also done via the loader and therefore it is connected and should therefore show the same version number.

Geoff
No as I said originally the two programs are completely separate, and therefore have completely separate version numbers.

As an aside pressing check for updates in the loader actually shuts down the loader and launches the totally separate refresher program.

"Platform 1 your Maesteg service. Platform 1A your Aberdare. Platform 2 your London!"
Log in to reply
Which version is correct please 11/04/2018 at 21:05 #107474
MarkC
Avatar
673 posts
Headshot posted as I was typing,
Only Going Forward, Still Can't Find Reverse
Last edited: 11/04/2018 at 22:04 by MarkC
Reason: None given

Log in to reply
Which version is correct please 11/04/2018 at 21:09 #107476
northroad
Avatar
741 posts
headshot119 in post 107473 said:
northroad in post 107472 said:
As I understand things, if I update the loader as and when to the next version 4.6.13, it will be done via the loader. So how do I keep up with any updates for the Update. Surely that is also done via the loader and therefore it is connected and should therefore show the same version number.

Geoff
No as I said originally the two programs are completely separate, and therefore have completely separate version numbers.

As an aside pressing check for updates in the loader actually shuts down the loader and launches the totally separate refresher program.
Thanks for that, but I must admit I do find all of these version numbers very confusing as I am sure others do.

Geoff

Never apologise son, it's a sign of weakness (John Wayne)
Log in to reply
Which version is correct please 11/04/2018 at 21:57 #107478
northroad
Avatar
741 posts
Confusion over version numbers and which is the latest seems to be at the heart of some of the posts on the forum, with the originator of the question either simply using the wrong version having not kept their system up to date or for what ever reason do not quote the version numbers and make the devs/admins job of checking the problem and giving an answer a lot easier.
Is it a question of people not knowing where to look for the version numbers or too many places showing differing information.
Take the Birmingham New Street simulation for example.
If you load the simulation and use the drop down from the Help box to show about and finding that the simulation version is version 1.5. However if you look at the Wiki and user manual for Birmingham New street the latest version shown is 1.4 and a date of 9th April 2018 which is only 2 days ago. The reason behind this could be that updated versions of the timetables could have been issued, but even if this was to be the case a simple update to the Wiki could reveal why. After all you would expect the user manual to be up to date or would you.

There must be a way to best show all the correct versions and I throw the topic open for debate.

Geoff

Never apologise son, it's a sign of weakness (John Wayne)
Log in to reply
Which version is correct please 11/04/2018 at 22:17 #107480
headshot119
Avatar
2723 posts
northroad in post 107478 said:
Confusion over version numbers and which is the latest seems to be at the heart of some of the posts on the forum, with the originator of the question either simply using the wrong version having not kept their system up to date or for what ever reason do not quote the version numbers and make the devs/admins job of checking the problem and giving an answer a lot easier.
Is it a question of people not knowing where to look for the version numbers or too many places showing differing information.
Take the Birmingham New Street simulation for example.
If you load the simulation and use the drop down from the Help box to show about and finding that the simulation version is version 1.5. However if you look at the Wiki and user manual for Birmingham New street the latest version shown is 1.4 and a date of 9th April 2018 which is only 2 days ago. The reason behind this could be that updated versions of the timetables could have been issued, but even if this was to be the case a simple update to the Wiki could reveal why. After all you would expect the user manual to be up to date or would you.

There must be a way to best show all the correct versions and I throw the topic open for debate.

Geoff
The place to look for the version number of the simulation you are running is in help > about. It tells you both the sim version, and the loader version in use.

The latest version of the simulation is always what is available on check for updates.

Updating timetable version doesn't affect the simulation version, so I don't know where you are going with that statement.

"Platform 1 your Maesteg service. Platform 1A your Aberdare. Platform 2 your London!"
Last edited: 11/04/2018 at 22:18 by headshot119
Reason: None given

Log in to reply
Which version is correct please 11/04/2018 at 22:28 #107481
Peter Bennet
Avatar
4382 posts
I suppose what would be useful, and I think I've asked for it for Developers, is an accessible central record of what's on the loader.

Peter

Stereotypes only have themselves to blame
Log in to reply
Which version is correct please 11/04/2018 at 22:31 #107482
northroad
Avatar
741 posts
Headshot,
The about on the actual simulation is showing version 1.5 of the simulation.
The User manual in the wiki is showing the simulation as version as 1.4.

By saying that the actual simulation about is correct (and I agree with you) as showing version 1.5 then you are also saying that the user manual in the wiki is not up to date.

I really am nit picking I know but it does lead to confusion.

Never apologise son, it's a sign of weakness (John Wayne)
Log in to reply
Which version is correct please 12/04/2018 at 09:09 #107488
Peter Bennet
Avatar
4382 posts
northroad in post 107482 said:
Headshot,
The about on the actual simulation is showing version 1.5 of the simulation.
The User manual in the wiki is showing the simulation as version as 1.4.

By saying that the actual simulation about is correct (and I agree with you) as showing version 1.5 then you are also saying that the user manual in the wiki is not up to date.

I really am nit picking I know but it does lead to confusion.
That's because one is an integral part of the sim data and the other requires manual intervention, which often gets overlooked.

Peter

Stereotypes only have themselves to blame
Log in to reply
Which version is correct please 12/04/2018 at 16:12 #107494
GeoffM
Avatar
3973 posts
northroad in post 107472 said:
As I understand things, if I update the loader as and when to the next version 4.6.13, it will be done via the loader. So how do I keep up with any updates for the Update. Surely that is also done via the loader and therefore it is connected and should therefore show the same version number.

Geoff
To change the version number of the Updater (or any other software) requires recompiling the source, testing it, applying the code signing certificates, and releasing. I will not be doing that just to keep the Loader and Updater version numbers in sync - there is no point anyway.

New Street was updated on two consecutive days, the second to fix an error introduced the previous day that had hitherto gone unnoticed. While the Wiki was therefore out of date when you looked a day or two later, I certainly wouldn't be using that as a single source of truth - each software already tells you that.

SimSig Boss. Website issues: Check here first: https://www.simsig.co.uk/Wiki/Show?page=newwebsite
Log in to reply
The following user said thank you: northroad
Which version is correct please 12/04/2018 at 20:12 #107498
northroad
Avatar
741 posts
Sorry I asked the question and I've got the message judging by the responses.
Never apologise son, it's a sign of weakness (John Wayne)
Log in to reply