Upcoming Games


Full list
Add a game

Timetable not loading (MAC)

You are here: Home > Forum > General > General questions, comments, and issues > Timetable not loading (MAC)

Page 1 of 1

Timetable not loading (MAC) 08/05/2018 at 17:36 #107867
CP17
Avatar
2 posts
Hello all.

I'm returning to SimSig, having played the game many years ago on my old windows computers. I've since moved to using Mac, and am keen to start playing again.

I have managed to download the Sim/Loader using PlayOnMac, and it appears to have worked well. I can load up the sims via the loader screen without problem, and they appear to be functional. However, I cannot get the timetables to load.

On starting a new simulation, when I get to the "select timetable" screen, pop-ups appear informing me: "Error loading data from C:\users\Public\Documents\Simsig\\Timetables\kingsx\Kings Cross 1985 0000Start.WTT" (specific timetable name of course varies), and repeats for all timetables. I can only start a sim without a timetable. The sim otherwise starts as normal.

When attempting to merge the timetables in as a workaround, it only seems to work in the Kings Cross sim for the (excellent) 1985 timetable. In the other sims (such as North Wales Coast, Derby, North East Wales, LUL Victoria Line and Stafford, as well as some of the demos for payware), using Open/Merge simply does nothing after I select the appropriate timetable.

If anyone has any suggestions, any help would be gratefully appreciated.

In the meantime, I shall be enduring a baptism of fire with the fiendish timetable that I can actually get working!

Log in to reply
Timetable not loading (MAC) 08/05/2018 at 17:39 #107868
headshot119
Avatar
3400 posts
I'm not sure what to suggest, as I use Play On Mac, and don't have any of the issues described.

Have you got full read and write permission on your virtual folders?

"CHECK Do you stop at Capenhurst?" - Opinions are my own and not those of my employer
Log in to reply
The following user said thank you: CP17
Timetable not loading (MAC) 08/05/2018 at 17:57 #107869
9pN1SEAp
Avatar
282 posts
Do timetables without spaces in their names work?

Also I note that it's got two consecutive \\'s, wonder if that's an issue on Mac?

Jamie S (JAMS)
Log in to reply
The following user said thank you: CP17
Timetable not loading (MAC) 08/05/2018 at 18:15 #107870
CP17
Avatar
2 posts
Thank you both for your speedy replies.

headshot119 in post 107868 said:
I'm not sure what to suggest, as I use Play On Mac, and don't have any of the issues described.

Have you got full read and write permission on your virtual folders?
I'm reasonably sure I do.

9pN1SEAp in post 107869 said:
Do timetables without spaces in their names work?

Also I note that it's got two consecutive \\'s, wonder if that's an issue on Mac?
The 1985 file that does work has a space. The others don't work, regardless of whether or not there's a space in the filename.

I was wondering about the \\ myself, but it seems to be able to find the files without any problem, just not do anything with them.

Log in to reply
Timetable not loading (MAC) 12/02/2020 at 17:18 #123269
Modano1000
Avatar
7 posts
Did you find the answer to this? Got exactly the same
Problem

Log in to reply
Timetable not loading (MAC) 12/02/2020 at 18:00 #123271
nroberts
Avatar
187 posts
I haven't used Play-on-Mac but as an IT person, I suggest it might be possible that there's that extra backslash which can be causing issues. Not all software will handle double backslashed the same way.

I suggest you try checking the folder mapping (I suppose it must be one of the options) and ensure that the "virtual" folder created does NOT have an ending backslash.

It might well be that there are different parts of code in SimSig itself which check or don't check for ending backslashes in a path before appending a new path with a backslash on it. Then again it may be nothing to do with SimSig itself but rather some other issue with Play-on-Mac.

If you can give it a try.

Log in to reply