Upcoming Games


Full list
Add a game

ARS behaving strangely with train 4M17 at Bightside Up/Dn East SL

You are here: Home > Forum > Simulations > Released > Sheffield (ROC) > ARS behaving strangely with train 4M17 at Bightside Up/Dn East SL

Page 1 of 1

ARS behaving strangely with train 4M17 at Bightside Up/Dn East SL 15/04/2019 at 14:39 #117599
Lyn-Greenwood
Avatar
162 posts
I'm sure ARS is not working correctly at Brightside Up/Dn East SL. In the 08-04-2015 (0400 start) timetable, 4M17 has a scheduled stop (04:25 to 04:55) in the Up direction at the above location, but ARS sets the exit route to signal 156 before 4M17 even arrives at the stopping point (signal 172). It's as though ARS thinks 4M17 doesn't have a scheduled stop there. The train does actually stop as per the timetable, but its ARS status is "Enough route set to 156" rather than "Waiting for booked 04:55", so when/if it decides to leave early, it just sets off rather than the crew making the normal phone call.

When 4M17 later stops in Heeley Up Loop, ARS behaves as it should, so what's going on at Brightside?

Has anyone else observed this behaviour?

For info, I'm running Loader v4.11 and Sheffield (ROC) sim data v1.2, so everything's up to date.

I've attached a saved session which shows the problem.

Post has attachments. Log in to view them.
Log in to reply
ARS behaving strangely with train 4M17 at Bightside Up/Dn East SL 15/04/2019 at 15:04 #117600
Albert
Avatar
574 posts
On other sims ARS sets routes for freight early if there is no train in the system scheduled to overtake the freight.

Edit: a good example is the Connington loop at Peterborough. If a train is late ARS will route it into & immediately out of the loop even if there's a class 1 behind.

AJP in games
Last edited: 15/04/2019 at 15:06 by Albert
Reason: None given

Log in to reply
ARS behaving strangely with train 4M17 at Bightside Up/Dn East SL 15/04/2019 at 15:47 #117604
GeoffM
Avatar
4367 posts
There was an issue with multiple locations for the same berth, causing a "wait for time" flag (WFT) to be overwritten - in this case, Brightside Loop had WFT but the junction did not, causing the junction's attributes on the berth to overwrite the loop's attributes. This has already been fixed and is being tested for the next Loader release.

On a side note, ARS does have the ability to run trains early if it would not delay other trains. It all depends on the developer whether trains should WFT at a particular location regardless.

SimSig Boss
Log in to reply
The following user said thank you: Lyn-Greenwood