Upcoming Games


Full list
Add a game

Loader V5 Released!

You are here: Home > Forum > General > Loader V5 > Loader V5 Released!

Page 10 of 11

Loader V5 Released! 29/06/2020 at 16:10 #128534
headshot119
Avatar
3679 posts
Online
If you download the installer from the website, yes it will install Version 5.0 of the loader, the normal process is you then run check for updates to get the latest version.

I wonder if you have the later version TLS or SSL turned off in your internet explorer settings which means it can't communicate with the server.

"As the last track dropped, and the route became free, came the cry BROMLEY " - Opinions are my own and not those of my employer
Log in to reply
Loader V5 Released! 29/06/2020 at 16:21 #128535
Chrisrail
Avatar
300 posts
indian_railways_fan in post 128533 said:
Yesterday I installed the new loader on a Windows-10 machine and it is working ok.
Today I have installed it on a Windows-7 machine and there is a strange issue!

It installs as VER 5 instead of VER-5.2 and also refuses to update itself. It also fails to communicate with the Simsig server(screenshot attached). I am unable to login. I checked the settings in Windows firewall and the loader is allowed to access the internet. The internet connection is working fine. I also downloaded the system files again just to be sure but it still installs as VER-5 and refuses to update itself.

When I press the "Check for Updates" button, it says Simsig is upto date.

However, for some reason, I found that many of the sims were already installed and appeared in the new game window despite the installation window not having run visibly. Also, the sims themselves seem to be working ok.
For the limited sessions I have played, both on Win 7 and 10 OS, I have found that the clock letters flicker every few seconds which is a little distracting.

Sorry if this has been mentioned earlier.

Khalid.

I had that on my work laptop, If I am on nights need something to do, Initially it was running the last testers v of 5.xxx and just used the updates button that only installed v5. I uninstalled it and installed again but this time from the downloads section and it installed fine.

Hope that helps

Log in to reply
Loader V5 Released! 30/06/2020 at 06:25 #128588
GeoffM
Avatar
5019 posts
Online
Progress so far:
30865: If too many obsolete files are listed, the message indicating this scrolls off the top of the screen.

Done

30867: Allow custom CSS in the new Show Timetable window, add the character encoding statement (possible cause of some symbols displaying incorrectly for some users), and see what can be done about positioning (very varied opinions)

...and...

30868: Allow users to specify their own CSS filenames (including 30867) so the updater doesn't overwrite them.

Partially done. CSS can now be specified for the Simplifier, the Train List, and the Show Timetable windows through F3 Options instead of files.

30873: Putting computer to sleep while using a dynamic license loses the license. This is by design, but it seems a lot of people are doing it. See if it can be improved.

The timeout period has been extended on the server and client, and upon waking it will attempt to obtain a license again. A save file is automatically produced.

The above is undergoing testing and should be available very soon. Work continues on the other tickets.

SimSig Boss
Log in to reply
The following users said thank you: bugsy, StepSig, Splodge, Mikhail
Loader V5 Released! 30/06/2020 at 13:04 #128606
indian_railways_fan
Avatar
67 posts
indian_railways_fan in post 128533 said:
Yesterday I installed the new loader on a Windows-10 machine and it is working ok.
Today I have installed it on a Windows-7 machine and there is a strange issue!

It installs as VER 5 instead of VER-5.2 and also refuses to update itself. It also fails to communicate with the Simsig server(screenshot attached). I am unable to login. I checked the settings in Windows firewall and the loader is allowed to access the internet. The internet connection is working fine. I also downloaded the system files again just to be sure but it still installs as VER-5 and refuses to update itself.

When I press the "Check for Updates" button, it says Simsig is upto date.
In the absence of any response from the developers, it seems I will need to wait till Vers-5.2 or higher to release directly on the website!
In desperation, I deleted the Simsig folder in documents and now I am not able to install any of the sims since the "Check for Updates" button constantly says, everything is upto date.

Incidentally, this happens even if I am not connected to the internet!

Khalid.

Log in to reply
Loader V5 Released! 30/06/2020 at 13:18 #128607
y10g9
Avatar
626 posts
indian_railways_fan in post 128606 said:
indian_railways_fan in post 128533 said:
Yesterday I installed the new loader on a Windows-10 machine and it is working ok.
Today I have installed it on a Windows-7 machine and there is a strange issue!

It installs as VER 5 instead of VER-5.2 and also refuses to update itself. It also fails to communicate with the Simsig server(screenshot attached). I am unable to login. I checked the settings in Windows firewall and the loader is allowed to access the internet. The internet connection is working fine. I also downloaded the system files again just to be sure but it still installs as VER-5 and refuses to update itself.

When I press the "Check for Updates" button, it says Simsig is upto date.
In the absence of any response from the developers, it seems I will need to wait till Vers-5.2 or higher to release directly on the website!
In desperation, I deleted the Simsig folder in documents and now I am not able to install any of the sims since the "Check for Updates" button constantly says, everything is upto date.

Incidentally, this happens even if I am not connected to the internet!

Khalid.
Karl did respond to you in the next post with a thought of there might be an issue with a internet explorer setting. Did you have a look at that before complaining that no one had responded to you?

Log in to reply
Loader V5 Released! 30/06/2020 at 13:28 #128608
indian_railways_fan
Avatar
67 posts
y10g9 in post 128607 said:
Karl did respond to you in the next post with a thought of there might be an issue with a internet explorer setting. Did you have a look at that before complaining that no one had responded to you?

Yes, I immediately enabled SSL/TLS(all versions) in the internet explorer but no improvement.I also tried by restarting the PC.
BTW, I am not aware who Karl is, as in a developer or an ordinary forum user. But I am sorry for not clarifying this and annoying your sensibilities.

Khalid.

Log in to reply
Loader V5 Released! 30/06/2020 at 14:02 #128611
Albert
Avatar
753 posts
Online
Karl is headshot119 and it referred to this post.
AJP in games
Log in to reply
Loader V5 Released! 30/06/2020 at 14:12 #128612
headshot119
Avatar
3679 posts
Online
indian_railways_fan in post 128608 said:
y10g9 in post 128607 said:
Karl did respond to you in the next post with a thought of there might be an issue with a internet explorer setting. Did you have a look at that before complaining that no one had responded to you?

Yes, I immediately enabled SSL/TLS(all versions) in the internet explorer but no improvement.I also tried by restarting the PC.
BTW, I am not aware who Karl is, as in a developer or an ordinary forum user. But I am sorry for not clarifying this and annoying your sensibilities.

Khalid.
I would try running SimSig Loader as an administrator, and see if that allows the update to run.

"As the last track dropped, and the route became free, came the cry BROMLEY " - Opinions are my own and not those of my employer
Log in to reply
Loader V5 Released! 30/06/2020 at 14:27 #128613
vloris
Avatar
35 posts
GeoffM in post 128588 said:
Progress so far:
..
30873: Putting computer to sleep while using a dynamic license loses the license. This is by design, but it seems a lot of people are doing it. See if it can be improved.

The timeout period has been extended on the server and client, and upon waking it will attempt to obtain a license again. A save file is automatically produced.
I lock my computer everytime I leave it, even if that is at home and for a few minutes. Right now that is enough to trip the license detection and have the simulation quit. Just extending the timeout sounds like a workaround that won't help much, but the second part sounds like a more promissing solution. Thanks!

My experience so far in the last few days is that locking the license doesn't help. I still get the message that I have no license and the simulation quits, even when the license is locked.

Log in to reply
Loader V5 Released! 30/06/2020 at 18:01 #128630
GeoffM
Avatar
5019 posts
Online
vloris in post 128613 said:
GeoffM in post 128588 said:
Progress so far:
..
30873: Putting computer to sleep while using a dynamic license loses the license. This is by design, but it seems a lot of people are doing it. See if it can be improved.

The timeout period has been extended on the server and client, and upon waking it will attempt to obtain a license again. A save file is automatically produced.
I lock my computer everytime I leave it, even if that is at home and for a few minutes. Right now that is enough to trip the license detection and have the simulation quit. Just extending the timeout sounds like a workaround that won't help much, but the second part sounds like a more promissing solution. Thanks!

My experience so far in the last few days is that locking the license doesn't help. I still get the message that I have no license and the simulation quits, even when the license is locked.
The timeout is for people on poor connections, or going through tunnels on the train. It was off by one, meaning it timed out much quicker than it should have been.

We are still looking at the other issues but will be releasing intermittent updates once the features therein have been tested and approved.

SimSig Boss
Log in to reply
The following user said thank you: bri2808
Loader V5 Released! 30/06/2020 at 20:39 #128665
lazzer
Avatar
485 posts
One thing I've just noticed with the timetable window (when clicking on a train's headcode). The majority of the time it pops up towards the left of the screen. It did this before, but when I moved it to the middle of the screen where I liked it, all future TT windows would open where the last one had been.

But now, all TT windows default back towards the left again. I know this sounds like a minor annoyance, but I am so used to the window appearing in the middle of the screen, it feels weird having to move my eyes left to read it.

Is there any way Simsig could remember where the last TT window opened, and open all future windows in the same place?

Last edited: 30/06/2020 at 21:19 by lazzer
Reason: None given

Log in to reply
Loader V5 Released! 01/07/2020 at 06:43 #128699
Phil-jmw
Avatar
529 posts
vloris in post 128613 said:
GeoffM in post 128588 said:
Progress so far:
..
30873: Putting computer to sleep while using a dynamic license loses the license. This is by design, but it seems a lot of people are doing it. See if it can be improved.

The timeout period has been extended on the server and client, and upon waking it will attempt to obtain a license again. A save file is automatically produced.
My experience so far in the last few days is that locking the license doesn't help. I still get the message that I have no license and the simulation quits, even when the license is locked.
Deleted. See next post.

Last edited: 01/07/2020 at 06:46 by Phil-jmw
Reason: None given

Log in to reply
Loader V5 Released! 01/07/2020 at 06:45 #128700
Phil-jmw
Avatar
529 posts
vloris in post 128613 said:
GeoffM in post 128588 said:
Progress so far:
..
30873: Putting computer to sleep while using a dynamic license loses the license. This is by design, but it seems a lot of people are doing it. See if it can be improved.

The timeout period has been extended on the server and client, and upon waking it will attempt to obtain a license again. A save file is automatically produced.
I lock my computer everytime I leave it, even if that is at home and for a few minutes. Right now that is enough to trip the license detection and have the simulation quit. Just extending the timeout sounds like a workaround that won't help much, but the second part sounds like a more promissing solution. Thanks!

My experience so far in the last few days is that locking the license doesn't help. I still get the message that I have no license and the simulation quits, even when the license is locked.
Our home internet can be a bit hit and miss at times so I've locked licences to my PC for the larger sims I don't run on my laptop to prevent losing a licence and sim crash if the internet goes down. When I lock my PC (if I know I'll come back to a sim later and don't want to reopen and resize everything) the licences remain without any issues.

Last edited: 01/07/2020 at 06:47 by Phil-jmw
Reason: None given

Log in to reply
Loader V5 Released! 01/07/2020 at 11:27 #128709
8stewartt
Avatar
25 posts
Morning,

I've manage to resolve the issues re the licences, and allocated them via the new loader (much better not having the license manager!).

The little tick box at the bottom "Only show installed and owned simulations" seems a good feature, however, all my owned sims have a little blue triangle in the corner now i have allocated the licenses and are showing green signals next to them, but when i click the check box, they vanish?

Is this meant to happen or have i not allocated my licenses correctly? the games work ok.

Cheers.

Log in to reply
Loader V5 Released! 01/07/2020 at 12:42 #128714
Steamer
Avatar
3225 posts
Online
8stewartt in post 128709 said:


The little tick box at the bottom "Only show installed and owned simulations" seems a good feature, however, all my owned sims have a little blue triangle in the corner now i have allocated the licenses and are showing green signals next to them, but when i click the check box, they vanish?

Is this meant to happen or have i not allocated my licenses correctly? the games work ok.

Cheers.
The license locking isn't fully working at the moment; work is ongoing to fix it.

"Don't stress/ relax/ let life roll off your backs./ Except for death and paying taxes/ everything in life.../ is only for now." (Avenue Q)
Log in to reply
Loader V5 Released! 01/07/2020 at 13:29 #128716
danners430
Avatar
22 posts
Another (possible) bug I think I've found with the new dynamic timetable window: on sims with ARS (I tested on Man Picc), the ARS Status box doesn't update correctly - if you manually refresh the window after the train has moved a block section on the sim, the ARS displays "Not found in ARS". Closing and reopening the TT window resolves this.
Log in to reply
Loader V5 Released! 01/07/2020 at 13:58 #128719
Hap
Avatar
403 posts
Online
danners430 in post 128716 said:
Another (possible) bug I think I've found with the new dynamic timetable window: on sims with ARS (I tested on Man Picc), the ARS Status box doesn't update correctly - if you manually refresh the window after the train has moved a block section on the sim, the ARS displays "Not found in ARS". Closing and reopening the TT window resolves this.
Is this happening only when a train enters the sim? I can't reproduce it with any train currently in sim, but can at the fringes.

HAP
Log in to reply
V5.3 CSS Abilities 01/07/2020 at 14:57 #128723
bri2808
Avatar
142 posts
How we getting on with the clock flickering Geoff? I know you mentioned you had an idea in mind

Thanks

Brian

Last edited: 01/07/2020 at 15:27 by headshot119
Reason: None given

Log in to reply
Loader V5 Released! 01/07/2020 at 15:03 #128724
danners430
Avatar
22 posts
Hap in post 128719 said:
danners430 in post 128716 said:
Another (possible) bug I think I've found with the new dynamic timetable window: on sims with ARS (I tested on Man Picc), the ARS Status box doesn't update correctly - if you manually refresh the window after the train has moved a block section on the sim, the ARS displays "Not found in ARS". Closing and reopening the TT window resolves this.
Is this happening only when a train enters the sim? I can't reproduce it with any train currently in sim, but can at the fringes.
No, it's whenever the train moves within any block section. Two screenshots attached - one with the train in the Burnage section, the other immediately after it moves into the next block, and I press the "Refresh" button.




Post has attachments. Log in to view them.
Log in to reply
Loader V5 Released! 01/07/2020 at 15:36 #128728
Albert
Avatar
753 posts
Online
Adding to that, if you click while the headcode is stepping from one berth to the next (in multiplayer this can happen due to network lag) you get an error message.
AJP in games
Log in to reply
Loader V5 Released! 01/07/2020 at 16:17 #128732
danners430
Avatar
22 posts
And finally if I may... I don't know if this has been a thing for a while, but when using multiple displays the timetable viewer sometimes opens in the most annoying of places, for example off the edge of the screen... is there a way to force the windows to always appear on the screen?
[attachment=11163]"TT viewer.PNG"[/attachment]

Post has attachments. Log in to view them.
Last edited: 01/07/2020 at 16:18 by danners430
Reason: None given

Log in to reply
Loader V5 Released! 01/07/2020 at 20:36 #128754
GeoffM
Avatar
5019 posts
Online
More progress (not released; under test):

30869: Add a Save Sim shortcut key

Not required - Ctrl+S already does this.

30960: Locked licenses can't be used offline

Fixed.

30835: Message window not high enough

Fixed. Reducing the height of the control window also decreased this window by enough pixels for Windows to reduce the number of visible lines of text from 3 to 2 (with title bar). Increased height slightly.

SimSig Boss
Log in to reply
The following user said thank you: welshdragon
Loader V5 Released! 03/07/2020 at 10:04 #128856
Ray
Avatar
166 posts
It might be an idea to incorporate a simple speed up or speed down control near the clock as an easy way to speed up or slow down the simulation without having to go into the main menu.
Log in to reply
Loader V5 Released! 03/07/2020 at 10:17 #128857
bugsy
Avatar
748 posts
Online
Ray in post 128856 said:
It might be an idea to incorporate a simple speed up or speed down control near the clock as an easy way to speed up or slow down the simulation without having to go into the main menu.

The Wiki states that you can do this using the + and - keys providing you have a numeric keypad. Have you got one?

Your life can have a thousand different meanings or maybe just one....I'd recommend more than one in case you got it wrong - (Rezende)
Log in to reply
Loader V5 Released! 03/07/2020 at 10:21 #128858
Meld
Avatar
737 posts
Online
Ray in post 128856 said:
It might be an idea to incorporate a simple speed up or speed down control near the clock as an easy way to speed up or slow down the simulation without having to go into the main menu.
But then it would be 'we need a normalise speed button as well' then another button for something else and so on and on it would go.

Give some love for the Whopper on the left hand side

Passed the age to be doing 'Spoon Feeding' !!!
Log in to reply